Eclipse Setup

Install Eclipse in the recommended way for your environment, and start it.  Then: 
  • Select Help -> Install New Software
  • Select a relevant site from the Work with dropdown
  • Select the following packages:
    • CDT Main Features -> C/C++ Development Tools
    • CDT Optional Features -> all (you may deselect Autotools support for CDT Source)
    • Collaboration -> Eclipse EGit
    • Programming Languages -> all (though you may deselect the following)
      •   Autotools Support for CDT (Incubation)
      •   C/C++ Development Tools SDK
      •   C++ Library API Documentation Hover/Help (Incubation)
      •   Fortran Development Tools
      •   IBM XLF Compiler Support
      •   Linux Fortran Compiler Support
      •   Object Teams *
  • Select Next >
  • Resolve any dependency conflicts and select Next > again
  • Accept the licenses and select Finish
Git Setup
  • Select File -> Import -> Git -> Projects from Git -> Next >
  • Select URI -> Next >
  • Enter the URI ssh://gerrit.chromium.org:29418/webm/libvpx
    • Eclipse parses the URI for other field data
  • Select Next >
  • Provide the passphrase for your SSH key, if prompted
  • Accept all the branches. Select Next >
  • Select a project directory, and make a note of it ($PROJECT_DIRECTORY). Select Finish
  • Eclipse does a git clone into the project directory
Before continuing, in a shell, do:

$ cd $PROJECT_DIRECTORY
$ ./configure --disable-codecs --enable-vp8 --target=x86_64-linux-gcc --enable-debug --disable-install-docs --log=yes --enable-internal-stats --enable-unit-tests

Return to Eclipse:
  • Run the New Project wizard
  • Select the wizard for C/C++ -> Makefile Project with Existing Code. Select Next >
  • Specify a project name, and the existing code location ($PROJECT_DIRECTORY)
  • Select the Linux GCC Toolchain
  • Select Finish
Adding Gerrit Support
  • Select Window -> Open Perspective -> Other... -> Git Repository Exploring -> OK
  • In the Git Repositories pane, expand the libvpx -> Remotes -> origin
  • Right-click origin and select Gerrit Configuration
  • Push URI should be correct.  Select Finish
Indexing and Content Assist (so that code references work) 
  • Select Window -> Preferences -> C/C++ -> Indexer
  • Check Enable Indexer, Index unused headers, and Allow heuristic resolution of includes, and click Apply
Missing includes?
  • Right-click project -> Properties -> Paths and Symbols -> Includes
  • Include Directories to add
    • /usr/include
    • /usr/include/linux
    • /usr/include/c++/4.4/tr1
Content Assist
  • Select Window -> Preferences -> C/C++ -> Editor -> Content Assist -> Advanced
  • Check Help Proposals, Parsing, Template and Word
To use, type in the start of a structure or parm and hit Ctrl+Space to see list of options. Also works for functions, etc. Now, as you type code, it shows you the errors in your code until you fix.

Style
  • Select Window -> Preferences -> Code Style -> Formatter -> Import
    • (Use the attached files)
  • Right-click project name -> Properties -> C/C++ General -> Formatter
  • Enable Project specific settings
  • Set Active profile to WEBM Project
  • FILTERING THE .o files
  • Project Explorer Triangle Menu -> Customize View
  • Select Object files to remove
To use, select text and press Ctrl+Shift-F to reformat the selection.

Debugging
  • Select Run -> Debug Configurations -> C/C++ Application -> New Button (upper left)
  • Search Project
  • vpxenc
ċ
eclipse-webm-style-settings.xml
(17k)
Lou Quillio,
May 3, 2012, 12:10 PM
Comments